xampp php 5.5.24 安全扫描有漏洞,根据php官方补丁如何修补?

漏洞
PHP libmagic/apprentice.c apprentice_load函数拒绝服务漏洞CVE-2014-9426

我看了半天php5.5.24已经是5.5里最新的版本了,整体升级好像不行,查漏软件给了几个链接,官方修改的.h文件,从没单独编译过php源码,不知道如何操作

  1. http://git.php.net/?p=php-src.git;a=commit;h=ef89ab2f99fbd9b7b714556d4…
  2. http://git.php.net/?p=php-src.git;a=commit;h=a72cd07f2983dc43a6bb35209…

服务器端吗 ? 还是建议不要用 XAMPP 这种 . 都自己安装 或者 编译安装吧 , 软件也好升级

你说那个bug 应该和 Linux 有关吧.

PHP #68665

大概主要的流程就是

php 编译安装

发表评论

电子邮件地址不会被公开。 必填项已用*标注