vim python第三方模块补全?

我在Ubuntu环境下下载jedi.vim可以对第三方模块进行补全。
但是在mac os环境下下载jedi.vim却不能对第三方模块进行补全,这是为什么?

Python 补全的话你可以使用 YouCompleteMe, 再安装 python-mode 插件就可以很好的进行补全了。

没用过Mac OS,我猜可能是Jedi 无法识别系统级库目录
jedi-vim 在我的Linux/Windows 上正常

另外,开发环境你不上 virtualenv?
试试 vim-virtualenv,也许能解决你的问题

Vundle是一个管理vim插件的扩展,按照教程配置后就可以了

YouCompleteMe安装的时候C++编译慢,但是按照后几乎什么也不用配置,直接使用

Syntastic可以自动检查C/C++这些Clang系,可以选择pip install pylint或flake8来让它支持python语法检查

目前用的是YouCompleteMe,不过补全功能有时工作不正常,我一般是在终端里面配置PYTHONPATH为PYTHON代码的根目录后,他才正确分析和补全import包中的代码

export PYTHONPATH=`pwd`
vim

我的mac是可用的,下面是配置

let g:jedi#use_tabs_not_buffers = 1 let g:SuperTabDefaultCompletionType = "<c-n>" let g:indent_guides_start_level = 2 let g:indent_guides_guide_size = 1 let g:indent_guides_enable_on_vim_startup = 1 

发表评论

电子邮件地址不会被公开。 必填项已用*标注